Commit 010b3485 authored by Mattias Ellert's avatar Mattias Ellert

Sqlite is no longer optional, the --enable-sqlite option no longer exists.

Fixes warnings from configure:
configure: WARNING: unrecognized options: --enable-sqlite
parent 78d47d6e
......@@ -891,7 +891,7 @@ PKG_CHECK_MODULES(SQLITE, [sqlite3 >= 3.6], [SQLITE_INSTALLED=yes] , [
])
if test "x$SQLITE_INSTALLED" = "xyes" ; then
AC_DEFINE(HAVE_SQLITE, 1, [define if SQLite is available])
# Check for finction available since 3.8
# Check for function available since 3.8
SAVE_CFLAGS=$CFLAGS
SAVE_LIBS=$LIBS
CFLAGS="$CFLAGS $SQLITE_CFLAGS"
......
......@@ -3,7 +3,7 @@ Section: net
Priority: optional
Maintainer: Mattias Ellert <mattias.ellert@physics.uu.se>
Uploaders: Anders Waananen <waananen@nbi.dk>
Build-Depends: debhelper (>= 9), dh-autoreconf, autopoint, libxml2-dev (>= 2.4.0), libssl-dev, libglibmm-2.4-dev, python-dev, libltdl-dev, libldap2-dev, uuid-dev, libcppunit-dev, pkg-config, libdb++-dev, libxmlsec1-dev (>= 1.2.4), libglobus-common-dev, libglobus-gssapi-gsi-dev, libglobus-ftp-client-dev, libglobus-ftp-control-dev, dh-python | python-support, openssl, swig, libnss3-dev, pylint, libjson-xs-perl, libxml-simple-perl, libdbi-perl, libsqlite3-dev, libinline-python-perl | dash, libldns-dev, python-twisted-core, python-twisted-web, python-openssl
Build-Depends: debhelper (>= 9), dh-autoreconf, autopoint, libxml2-dev (>= 2.4.0), libssl-dev, libglibmm-2.4-dev, python-dev, libltdl-dev, libldap2-dev, uuid-dev, libcppunit-dev, pkg-config, libdb++-dev, libxmlsec1-dev (>= 1.2.4), libglobus-common-dev, libglobus-gssapi-gsi-dev, libglobus-ftp-client-dev, libglobus-ftp-control-dev, dh-python | python-support, openssl, swig, libnss3-dev, pylint, libjson-xs-perl, libxml-simple-perl, libdbi-perl, libsqlite3-dev (>= 3.6), libinline-python-perl | dash, libldns-dev, python-twisted-core, python-twisted-web, python-openssl
XS-Python-Version: current
Standards-Version: 4.0.0
Homepage: http://www.nordugrid.org
......
......@@ -42,7 +42,6 @@ configure-stamp:
--infodir='$${datadir}/info' \
--disable-doc \
--with-docdir='$${datadir}/doc/nordugrid-arc' \
--enable-sqlite \
--enable-internal
touch $@
......
......@@ -110,13 +110,6 @@
%global with_pythonlrms 0
%endif
# SQLite
%if %{?fedora}%{!?fedora:0} >= 11 || %{?rhel}%{!?rhel:0} >= 6
%global with_sqlite 1
%else
%global with_sqlite 0
%endif
# LDNS
%if %{?fedora}%{!?fedora:0} >= 13 || %{?rhel}%{!?rhel:0} >= 5
%global with_ldns 1
......@@ -304,9 +297,7 @@ BuildRequires: libtool
BuildRequires: perl(Inline)
BuildRequires: perl(Inline::Python)
%endif
%if %{with_sqlite}
BuildRequires: sqlite-devel >= 3.6
%endif
%if %{with_ldns}
BuildRequires: ldns-devel >= 1.6.8
%endif
......@@ -865,9 +856,6 @@ fi
%if %{with_pythonlrms}
--with-inline-python \
%endif
%if %{with_sqlite}
--enable-sqlite \
%endif
%if ! %{with_ldns}
--disable-ldns \
%endif
......@@ -1238,10 +1226,7 @@ service arc-infosys-ldap condrestart > /dev/null 2>&1 || :
%{_libexecdir}/%{pkgdir}/cache-list
%{_libexecdir}/%{pkgdir}/jura
%{_libexecdir}/%{pkgdir}/jura-archive-manager
%if %{with_sqlite}
%{_libexecdir}/%{pkgdir}/gm-delegations-converter
%doc %{_mandir}/man8/gm-delegations-converter.8*
%endif
%{_libexecdir}/%{pkgdir}/gm-jobs
%{_libexecdir}/%{pkgdir}/gm-kick
%{_libexecdir}/%{pkgdir}/smtp-send
......@@ -1299,6 +1284,7 @@ service arc-infosys-ldap condrestart > /dev/null 2>&1 || :
%doc %{_mandir}/man1/cache-clean.1*
%doc %{_mandir}/man1/cache-list.1*
%doc %{_mandir}/man1/jura.1*
%doc %{_mandir}/man8/gm-delegations-converter.8*
%doc %{_mandir}/man8/gm-jobs.8*
%doc %{_mandir}/man8/arc-blahp-logger.8*
%doc %{_mandir}/man8/a-rex-backtrace-collect.8*
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment