Commit 61091a3e authored by Mattias Ellert's avatar Mattias Ellert

Remove workaround for autoconf < 2.60 no longer needed

parent 7296091d
......@@ -75,26 +75,6 @@ AC_PATH_PROG(PERL, perl, /usr/bin/perl, :)
test -n "$MKDIR_P" || MKDIR_P="$mkdir_p"
AC_SUBST([MKDIR_P])
dnl --with-docdir since older autoconf (<2.60) does not support --docdir
AC_ARG_WITH([docdir],
AC_HELP_STRING([--with-docdir=DIR],
[Install documentation in DIR [[default: ${datadir}/doc]]]),
[case $withval in
yes|no)
AC_MSG_ERROR([Invalid DIR])
;;
*)
docdir="$withval"
;;
esac
],
[
if test -z "$docdir"; then
docdir='${datadir}/doc/${PACKAGE}'
fi
])
AC_SUBST(docdir)
# Use arc for "pkgdir" instead of nordugrid-arc (@PACKAGE@)
pkgdatadir='${datadir}/arc'
pkgincludedir='${includedir}/arc'
......
......@@ -41,7 +41,7 @@ configure-stamp:
--mandir='$${datadir}/man' \
--infodir='$${datadir}/info' \
--disable-doc \
--with-docdir='$${datadir}/doc/nordugrid-arc' \
--docdir='$${datadir}/doc/nordugrid-arc' \
--enable-internal
touch $@
......
......@@ -865,7 +865,7 @@ fi
--with-systemd-units-location=%{_unitdir} \
%endif
--disable-doc \
--with-docdir=%{_pkgdocdir}
--docdir=%{_pkgdocdir}
make %{?_smp_mflags}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment