Commit c60e6522 authored by Maiken's avatar Maiken
Browse files

Merge branch 'release_notes_6.8.1' into 'master'

Release notes for ARC 6.8.1

See merge request !1059
parents 52f2f632 9220a797
Pipeline #8453 passed with stages
in 121 minutes and 37 seconds
Advanced Resource Connector (ARC)
=================================
Release Notes for NorduGrid ARC 6.8.1 08.10.2020
------------------------------------------------------
This is an express release which targets purely the arc.conf changes related to the
deprecated arc.conf values in ARC 6.8.0
In ARC 6.8.0 the ARC validator would prevent ARC from starting up if any of the
deprecated blocks and options were present in arc.conf. From 6.8.1 ARC will start
even with the deprecated options in place. Note however that they are still
deprecated and should be removed. The options will have no effect to your running
instance of ARC, thus of no value.
The deprecated arc.conf values in ARC 6.8.0 are
-------------------------------------------------
* In the [arex/jura] block:
* urdelivery_keepfailed (in [arex/jura] block)
* In the [arex/jura/sgas:targetname] block:
* legacy_fallback
* In the [arex/jura/apel:targetname] block:
* use_ssl
* benchmark_type
* benchmark_value
* benchmark_description
* legacy_fallback
* [arex/jura/archiving] block (the whole block is deprecated)
* archivedir
* logfile
* archivettl
For all the other changes included in 6.8.0, please refer to the release notes:
http://www.nordugrid.org/arc/releases/6.8/release_notes_6.8.html
Important note on xrootd version for sites using the nordugrid-arc-plugins-xrootd package
------------------------------------------------------------------------------------------
For sites who install the nordugrid-arc-plugins-xrootd package note that ARC 6.8.0 is built with xrootd 5.
On the date of the release xrootd 5 has not yet reached EPEL-stable which means that to install(update) ARC 6.8.0 on RHEL-systems,
you must enable the epel-testing repo:
yum install(update) "nordugrid-arc*" --enablerepo=epel-testing
or alternatively install xrootd 5 before updating ARC.
Documentation
==============
The ARC 6 documentation can be found at http://www.nordugrid.org/arc/arc6
If you miss something or have questions, please contact us!
Installing ARC 6
=================
We recommend to install ARC release using the Nordugrid repository.
* Start with the basics: http://www.nordugrid.org/arc/arc6/admins/try_arc6.html
* Get production ready: http://www.nordugrid.org/arc/arc6/admins/arc6_install_guide.html
Note that if you instead install from EPEL for RHEL 7 compatible systems,
the ARC 6 packages can be found as nordugrid-arc6-* and not nordugrid-arc-*
This was needed in order to supply both ARC 5 already available for RHEL7 and the new ARC 6.
We provide binary builds for all supported versions of
* Debian (i386 and amd64)
* Fedora (i386 and x86_64) - from Fedora 26 - no i386 support
* CentOS EL6 (i386 and x86_64) and EL7/EL8 (x86_64) - from EL7 no i386 support
* Ubuntu (i386 and amd64, both LTS and interim releases) - from Ubuntu 20.04 no i386 support
In addition we build nightly packages for older platforms.
Future support of ARC 5-series
===============================
As of June 2020 no more security updates are provided to ARC 5.
Also since the release of ARC 6 in June 2019, no more development on the ARC 5 code base has been provided.
Production Sites already running ARC 5 will still get operational site support in form of
deployment and configuration troubleshooting help via GGUS until end June 2021.
However, we may recommend upgrading to ARC 6 depending on the issues the site is facing.
ARC5 is available in EPEL7 and will stay there. EPEL8 will only contain ARC 6.
To install ARC 6 from EPEL7 the package-names are of type: nordugrid-arc6-*
Getting in touch
==================
If you need help with the configuration file or have any other questions related to ARC 6, please contact us via
* Email: nordugrid-discuss@nordugrid.org or wlcg-arc-ce-discuss@cern.ch
* Skype channel dedicated to ARC 6 support: https://join.skype.com/dyf3A6Uutjy2
Known issues
==============
* For sites with nordugrid-plugins-xrootd installed epel-testing repo must be enabled, otherwise update will fail.
This is because at the time of the 6.8.0 release the xrootd 5 had not yet reached epel-stable, and ARC is built
with xrootd 5.
* In Centos8 the openldap server is not installable because slapd is not available in the RHEL8 release (Bugzilla 3944).
As a consequence, the LDAP-based server-side information system interface of the ARC-CE will not be available either.
If interaction with the ARC-CE relies on LDAP-based information schemas (glue1.3 or nordugrid schema),
then we recommend that you stay with Centos7 for the time being.
* Related to the new accounting system introduded in release 6.4.0:
** Accounting records created by ARC 6.4.0 are affected by a bug causing missing benchmark values:
https://bugzilla.nordugrid.org./show_bug.cgi?id=3921#c3
Recommendations are to update to a newer version of ARC.
The bugreport gives instructions on how to manually fix the wrong benchmark values.
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment