Commit 3801d598 authored by Maiken's avatar Maiken

Merge branch 'slapd-rh8' into 'master'

Downgrade slapd dependency on EPEL 8

See merge request nordugrid/arc!1101
parents 6ad90b07 8baaa3bf
Pipeline #8943 failed with stage
in 80 minutes and 2 seconds
......@@ -649,11 +649,10 @@ Conflicts:
nordugrid-arc-gridmap-utils (<< 6.0.0~)
Architecture: all
Depends:
libnet-ldap-perl,
libxml-dom-perl,
libcrypt-ssleay-perl,
liblwp-protocol-https-perl,
libsoap-lite-perl,
libcrypt-openssl-x509-perl,
liburi-perl,
libxml-dom-perl,
${perl:Depends},
${misc:Depends}
Recommends:
......
......@@ -407,9 +407,15 @@ Group: System Environment/Libraries
%if %{?fedora}%{!?fedora:0} >= 10 || %{?rhel}%{!?rhel:0} >= 6
BuildArch: noarch
%endif
%if %{?rhel}%{!?rhel:0} == 8
# slapd package not available in EPEL 8
Recommends: openldap-servers
Recommends: bdii
%else
Requires: openldap-servers
Requires: glue-schema >= 2.0.10
Requires: bdii
%endif
Requires: glue-schema >= 2.0.10
Requires: %{name}-arcctl-service = %{version}-%{release}
Provides: %{name}-ldap-infosys = %{version}-%{release}
Obsoletes: %{name}-ldap-infosys < 6.0.0
......@@ -909,8 +915,6 @@ Python 3 bindings for ARC.
%package nordugridmap
Summary: ARC's nordugridmap tool
Group: Applications/Internet
Requires: perl(Crypt::SSLeay)
Requires: perl(Crypt::OpenSSL::X509)
Requires: crontabs
Obsoletes: %{name}-gridmap-utils < 6.0.0
%if %{?fedora}%{!?fedora:0} >= 10 || %{?rhel}%{!?rhel:0} >= 6
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment